Home Forums 360° Virtual Tours Hosting virtual tour on Amazon S3 — loads white page

This topic contains 2 replies, has 2 voices, and was last updated by  Harrison Moore 3 months, 2 weeks ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #16205

    Harrison Moore
    Forum Member

    Let me preface this by apologizing if this post is redundant or in the wrong place.
    I have set up a bucket for static web hosting on Amazon S3, and made it public through bucket policy and CORS configuration.
    I uploaded all of the files from my tour (created in Panotour 2.5), including the tour’s .html file. S3 said that one or more of the files failed to upload, but I can’t find anything missing.
    After using the tour’s .html file as part of the static web hosting, I attempted to run the tour. The link works, and the browser tab reads “| Virtual Tour generated by Panotour” but displays a blank page.
    What am I doing wrong?

    #16721

    eladnova
    Forum Member

    Hi Harrison
    I haven’t done too much S3 hosting but you might check the following.

    Are any files missing from the upload? If your browser tab has a title then you’ve got your html file there but what about all your JS files and or images?

    Have you tried to do a web inspect using the Chrome Dev toolbar? This will often flag missing files etc

    Does the 360 work before you upload it? Does it work when uploaded to a different host?

    Feel free to pop me the link and I’ll have a look if it’s not under NDA etc

    #16724

    Harrison Moore
    Forum Member

    Thanks for responding.
    I found out that all the files (except the HTML file) have to be in the original folder, not unpacked like I had done when I wrote the first post.
    Again, thanks for responding!
    Harrison

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.